Changing background colour


#1

Hi Satish,

I’m trying to change the background colour from grey to white. I’ve done this by going to “Override the SCSS variables” and adding:
$sb1-bg: #fff;
$sb2-bg: #fff;

Is that right? It doesn’t seem to be changing anything. I’ve tried clicking the “Clear Transients” button too.
Thanks,
Charles


#2

Hi Charles,
Sorry for the delay in getting back.
If you are using separate containers for sidebars and main, it won’t have any affect.
Otherwise, your changes are fine.
Please share your site URL.


#3

Hmmm I’m not sure if I’m using separate containers for sidebars and main…
Here is the link to the website: http://wp-staging.privatebox.online


#4

Those are not sidebars.
Its the margin on either side of your fixed with layout.

There are three ways to get what you want.

  1. In colour and background options, set body background to the colour of your choice. You won’t see the change yet. Select the "Make backgrounds transparent" option.
  2. Add $wrapper-bg:#fff; to Override the SCSS variables”
  3. Add #wrapper{background:#fff} to additional CSS.

Hope that helps :slight_smile:


#5

Hi Satish,

Thanks for those options. Unfortunately none of them worked.

Just to confirm it is the grey area on the left and right of the content that I want to change to white.


#6

Ah, I was able to get the white to show with the third option and adding “!important” to the custom CSS.

There seems to be some grey color coming from somewhere. Do you know where that is set? I can’t find it in the SCSS files. (All of my background options are set to #fff)


closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.