Images on subdomain


#1

Hi,

Just to make things more complicated (well actually, to try and reduce the page loading speed still more ;-)) I’ve moved all the images on our website to a subdomain. I changed the URL for the path to media in the settings on the dashboard, and updated the database with the new url.

The images are mostly loading but the thumbnails aren’t being generated in the right size and they’ve lost their movement/wiggle when you hover over them, and the background (featured) image on the blog pages no longer load at all.

Any ideas what could be causing this? I tried deleted and reinstalling the Dynamic Thumbnails plugin but it didn’t make any different. I’ll pm you the link.


#2

Please share your site url.


#3

Did you move your existing uploads directory to the new subdomain?
How did you make the move?
Why not use a CDN?

Please share your login.


#4

Yes, I moved the uploads to the new subdomain, with ftp. I didn’t know a CDN could help with this (and actually I thought we were signed up to one already; Cloudflare). I’ll pm you the login.


#5

Just to explain: I did a workaround on the latest image I uploaded (earlier today), using ftp to put it in the subdomain, because the Dashboard’s uploading function didn’t work. It’s displaying correctly now on the home page slider but not in the Media Library (in the dashboard).

The Media Library shows all the other image thumbnails and claims to be loading them from the subdomain, and when I look at the images on the front end of the site, they’re also coming from the subdomain now. So it’s quite odd that I can’t seem to upload to the Library via the dashboard.


#6

If it’s too complicated to resolve I could just move the images back to the original Uploads folder.


#7

I’ve redirected the website path back to the original uploads folder as there’ll be assessors looking at the website this week. But if you have time to take a look at some point, just let me know and I can change the path back.


#8

Did you change the upload path at settings ->media?
You should give relative path to your subdomain here.


closed #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.